summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml28
1 files changed, 24 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e74c9ec..30773d7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,26 @@
[build-system]
-requires = [
- "setuptools>=42",
- "wheel"
+requires = ["pbr>=5.7.0", "setuptools>=36.6.0"]
+build-backend = "pbr.build"
+
+[tool.pytest.ini_options]
+addopts = "--cov-report term-missing --cov=pyssg"
+testpaths = [
+ "tests",
]
-build-backend = "setuptools.build_meta"
+env = [
+ "PYMDVAR_TEST_1=1"
+]
+
+[tool.mypy]
+mypy_path = "src"
+check_untyped_defs = true
+disallow_any_generics = true
+ignore_missing_imports = true
+no_implicit_optional = true
+show_error_codes = true
+strict_equality = true
+warn_redundant_casts = true
+warn_return_any = true
+warn_unreachable = true
+warn_unused_configs = true
+no_implicit_reexport = true